No. Changing the names is obviously fine, but use the syntax Marvin kindly gave you instead of making up your own.
Condition: not alive target1 and not alive target2 and not alive ural
Activation: blah blah blah
Head over to the comref and read up on the commands:-
and
not
or
Also read Scripting topics.
Now, there is an extra subtlety here. If "ural" is a vehicle then don't use the alive command. It's not very helpful with vehicles, because the vehicle can look destroyed when it is not. Alive is best for loons. For the ural you could use
(not canMove ural) and (not alive uralD)
Or you could have a trigger
Condition: getDammage ural > 0.8
Activation: ural setDammage 1
and then use "ural getDammage > 0.9" as your ending condition.
Edit: beaten again